Reply
Bronze Contributor
Sleepyshaz
Posts: 19
Registered: ‎12-05-2008

SMTP settings for an O2 email account

This question has probably been answered a million times. I have an iphone, have my iphone set up to receive emails from my O2 email account but can't find the smtp settings to send emails from my iphone in this account!! Help anyone?!
Please use plain text.
O2_Daryll
Posts: 34,994
Topics: 584
Kudos: 8,781
Solutions: 1,032
Registered: ‎23-04-2008

Re: SMTP settings for an O2 email account

There’s a slight bug in the iPhone mail setup that won’t let you configure without SSL but there’s a workaround. Here are the steps:

On the iPhone go to Settings> Mail. Choose to Add a New account, enter the user details, choose POP.

Then for the following enter:

Incoming Mail Server:
Host Name: pop.o2.ie
Username: Your O2.ie email address
Password: Your O2.ie password

Outgoing Mail Server:
Hostname: smtp.o2.ie
Username: Can leave blank
Password: Can leave blank

It will then try and configure your account using SSL, it will fail and after 30 seconds ask if you would like to configure without SSL. Choose Yes. It will then give an authentication error. You can accept this but still save the settings that you have entered. It will then give an error telling you that the email probably won’t work, accept this. Go back into Settings> Mail. Choose the O2.ie email account, go to Advanced, turn Use SSL to OFF. Go back and ensure the smtp server name (smtp.o2.ie) is in the smtp field. If you then go back out to Mail on the home screen> under accounts (if you have more then one) your email should then load.
A bit long winded but it works.
New to the forum? Click here
Tagging your posts and others with relevant key words is another way to help,
it also counts towards forum rank.
Please use plain text.
Silver Contributor
rdunne
Posts: 41
Registered: ‎10-11-2008

Re: SMTP settings for an O2 email account

When accessing O2 server settings initially on my phone, the incoming pop3 port number is defaulted to 110. which is correct, The outgoing smtp port default is 587, which should also be 110. Just in case anyone is having difficulties accessing 02 email on their phone.
Please use plain text.
Silver Newbie
Cormac8206
Posts: 4
Registered: ‎07-09-2011

Re: SMTP settings for an O2 email account

Dear O2_Daryll, I recently upgraded to an iPhone 3. It does everything I want, except I can't send an email when I'm outside wi-fi range. I can receive emails OK. My email and wifi setup is with UPC, and with them I have retained my old celalor@eircom.net email address. I read your reply to "sleepyshaz" (23-01-2010) and I tried to follow it, but although the system appeared to do everything as you said, when I tried to send an email from outside, I got the following message: "A copy has been placed in your Outbox. The recipient "%@" was rejected by the server because the user is unknown" I had 3G enabled and cellular data ON. When I walked back home and into wi-fi range, the message was sent by wi-fi from my Outbox. Can you set me straight? Thanks and best regards, Cormac Lalor.
Please use plain text.
O2_Laura
Posts: 2,804
Topics: 1
Kudos: 1,294
Solutions: 130
Registered: ‎31-08-2010

Re: SMTP settings for an O2 email account

Hi Cormac, this is down to your outgoing mail server. When you are connected to the mobile internet, not wifi, your outgoing mail server should be set to smtp.o2.ie.

When you are connected to wifi the outgoing mail server should be set to your wifi providers server.
New to the forum? Click here
Tagging your posts and others with relevant key words is another way to help,
it also counts towards forum rank.
Please use plain text.
Silver Newbie
Cormac8206
Posts: 4
Registered: ‎07-09-2011

Re: SMTP settings for an O2 email account

Thanks for your prompt reply, Laura. Yes, I had set the outgoing mail server to smtp,o2.ie as advised by Daryll. No luck. I do not have an O2 email account, but as I said, I am with UPC, and have retained my eircom.net email address. Still need help! Thanks and best regards, Cormac.

Please use plain text.
O2_Laura
Posts: 2,804
Topics: 1
Kudos: 1,294
Solutions: 130
Registered: ‎31-08-2010

Re: SMTP settings for an O2 email account

Can you make sure that this is the primary outgoing server and then switch off the wifi and try to send an email please?
New to the forum? Click here
Tagging your posts and others with relevant key words is another way to help,
it also counts towards forum rank.
Please use plain text.
Silver Newbie
Cormac8206
Posts: 4
Registered: ‎07-09-2011

Re: SMTP settings for an O2 email account

I did - no good, I'm afraid!

Please use plain text.
O2_Sheena
Posts: 15,082
Topics: 131
Kudos: 7,313
Solutions: 1,331
Registered: ‎07-04-2010

Re: SMTP settings for an O2 email account

Have you the incoming server set to webmail.eircom.net with the correct username and password for Eircom.net entered?
Please use plain text.
Silver Newbie
Cormac8206
Posts: 4
Registered: ‎07-09-2011

Re: SMTP settings for an O2 email account

I have. Also Server Port 25 (if that's important). As far as I can make out, having set up a new account, I replicated everything just like the old account, except that the outgoing primary server is smtp.o2.ie instead of smtp.upcmail.ie. Also I tried, instead of creating a new account, to add another server in the old account. Neither plan worked. Thanks for all your efforts so far - we'll get there yet!

Please use plain text.
O2_Daryll
Posts: 34,994
Topics: 584
Kudos: 8,781
Solutions: 1,032
Registered: ‎23-04-2008

Re: SMTP settings for an O2 email account

If it is not working after all this I would advise doing something else completely.

Do you have a Gmail address?
New to the forum? Click here
Tagging your posts and others with relevant key words is another way to help,
it also counts towards forum rank.
Please use plain text.